博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
HDU 影子问题
阅读量:4617 次
发布时间:2019-06-09

本文共 1476 字,大约阅读时间需要 4 分钟。

Problem Description
Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers H, h and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

32 1 0.52 0.5 34 3 4

Sample Output

1.0000.7504.000

我感觉这就是一道数学题:

#include<stdio.h>

#include<math.h>
int main()
{
    int n;
    double H,D,h,s1,s2,x1,x2,i,s;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%lf%lf%lf",&H,&h,&D);
        s1=D*h/H;
        x1=D*(H-h)/H;
        x2=sqrt(D*(H-h));
        s2=(-x2*x2+x2*(D+H)+D*(h-H))/x2;
        if(x2<=x1)
        s=s1;
        if(x2>=D)
        {
            if(s1>=h)
                s=s1;
            else
                s=h;
        }
        if(x2<D  &&  x2>x1)
        {
             if(s1>=s2)
             s=s1;
        else
            s=s2;
        }
        printf("%.3f\n",s);
    }
    return 0;
}

转载于:https://www.cnblogs.com/zhanpang/p/5682912.html

你可能感兴趣的文章
生产环境下正则的应用实例(一)
查看>>
在CentOS7命令行模式下安装虚拟机
查看>>
Arduino可穿戴开发入门教程Arduino开发环境介绍
查看>>
Windows平台flex+gcc词法分析实验工具包
查看>>
3.Python基础 序列sequence
查看>>
Chapter 4 Syntax Analysis
查看>>
vi/vim使用
查看>>
讨论Spring整合Mybatis时一级缓存失效得问题
查看>>
Maven私服配置Setting和Pom文件
查看>>
Linux搭建Nexus3.X构建maven私服
查看>>
Notepad++使用NppFTP插件编辑linux上的文件
查看>>
NPOI 操作Excel
查看>>
MySql【Error笔记】
查看>>
vue入门
查看>>
JS线程Web worker
查看>>
Flex的动画效果与变换!(三)(完)
查看>>
mysql常见错误码
查看>>
Openresty 与 Tengine
查看>>
使用XV-11激光雷达做hector_slam
查看>>
布局技巧4:使用ViewStub
查看>>